Home > Python Error > Python Error Pythreadstate_get No Current Thread

Python Error Pythreadstate_get No Current Thread

Contents

We may make trace mode the default in a future release of MacPorts. desert0616 commented May 4, 2016 @lantiga Hi, I was wondering that there is any temporary approach to handling this problem. Thanks!P.s. To find out which library uses the latter, I would run otool -L on each of the dynamic libraries in the list of Binary Images, and see which ones is check over here

I think if one has a fresh homebrew and never had installed brew install python, then there is no sitecustomize.py file in the $(brew --prefix)/lib/python2.7/site-packages and as a consequence of that Checked that a similar issue hasn't already been filed? build 5493)] on darwinType "help", "copyright", "credits" or "license" for more information.>>> import ROOTFatal Python error: PyThreadState_Get: no current threadAbort trap: 6Trying to debug with lldb (apple decided to get rid benjaminhawkeslewis commented Sep 9, 2014 Not sure the PATH is the problem? http://stackoverflow.com/questions/15678153/homebrew-python-on-mac-os-x-10-8-fatal-python-error-pythreadstate-get-no-cu

Fatal Python Error: Pythreadstate_get: No Current Thread Vtk

I also had a look at VTK cmake files and tried to hack something together (as I patched ITK lately for the same problem with success) The thing with VTK is My crash also is "Fatal Python error: PyThreadState_Get: no current thread Abort trap: 6". Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. python module homebrew mapnik share|improve this question asked Mar 28 '13 at 9:23 otmezger 2,05872963 1 Indeed, this error shows up when a module tries to use a python library

If you build your own software and it requires this formula, you'll need to add to your build variables: LDFLAGS: -L/Users/benjamin/homebrew/opt/readline/lib CPPFLAGS: -I/Users/benjamin/homebrew/opt/readline/include ==> Summary 🍺 /Users/benjamin/homebrew/Cellar/readline/6.3.8: 40 files, 2.1M, built Should a country name in a country selection list be the country's local name? Consider setting the PATH for example like so echo export PATH='/Users/benjamin/homebrew/bin:$PATH' >> ~/.bash_profile (localhost ~)% homebrew/bin/brew install python ==> Installing dependencies for python: pkg-config, readline, sqlite, gdbm, makedepend, openssl ==> Installing Fatal Python Error: Pythreadstate_get: No Current Thread Anaconda I can import gtk.

valbertoenoc commented Aug 14, 2016 TL;DR: brew vtk works fine with brew python3. @iMichka , I have been moving around this issue for a while now, and I finally, arrived at Make sure that they're consistent, by having the custom python you intend to use first up in $PATH (and by pointing --with-python-libdir and --with-python-incdir to your custom python as needed).(In general, If you try to import the vtk you built with a python 3 coming from anaconda, macports, or from the python.org website, it would still crash. https://github.com/Homebrew/homebrew-science/issues/3401 is there anyway to make PyRosetta working if PYTHONPAT is not /usr/bin/python?

Please do not use this in production :) We used the same strategy in ITK and SimpleITK to fix this problem. Mayavi Fatal Python Error: Pythreadstate_get: No Current Thread We also have to decide whether the formulas pygobject, py2cairo, and pygtk are installing their python libraries in the correct site-packages directory for your non-standard setup, and we have to decide https://github.com/mxcl/homebrew/wiki/Common-Issues jmendeth referenced this issue in jmendeth/PyOpenNI Dec 16, 2012 Open Abort Trap on OS X 10.8 #33 pavel-zdenek commented Nov 21, 2013 Got the thread error after upgrading MacOS to In case it illuminates, I also ran otool against my /usr/local-installation Graphviz (which does not have the depends_on :python patch): (localhost ~)% otool -L $(brew --prefix)/lib/python2.7/site-packages/_gv.so /usr/local/lib/python2.7/site-packages/_gv.so: /usr/local/Cellar/graphviz/2.38.0/lib/libgvc.6.dylib (compatibility version 7.0.0,

Fatal Python Error: Pythreadstate_get: No Current Thread Swig

Bug reports / build errors: After PR #3313 (see also discussion there), which leads vtk to link to system python when it is available, makes it impossible to have vtk coexist https://trac.macports.org/ticket/41761 I find this problem is so common, but I didn't find the solution on the Internet. Fatal Python Error: Pythreadstate_get: No Current Thread Vtk Thanks for the report though. Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew both import cairo inside a python interpreter and brew test pygtk work for me now!

Even with depends_on :python, if Homebrew python isn't first in PATH then graphviz will link against system Python and cause problems when it's imported from a different Python. check my blog Generally to fix you need to call otool -L on boost_python.dylib and or on 'site_packages/mapnik/_mapnik.so' to see which ended up with a linkage to the system python. Despite using Homebrew, I'm not entirely familiar how it's backend scripts work for pulling other patches in. Abort trap: 6 As an aside: - /usr/bin/python -c "import vtk" => Ok To confirm, in Scenario 3: otool -L /usr/local/lib/python2.7/site-packages/vtk/vtkCommonCorePython.so gives /usr/local/lib/python2.7/site-packages/vtk/vtkCommonCorePython.so: /usr/local/Cellar/vtk/7.0.0/lib/libvtkCommonCorePython27D-7.0.1.dylib (compatibility version 1.0.0, current version 1.0.0) /usr/local/Cellar/vtk/7.0.0/lib/libvtkWrappingPython27Core-7.0.1.dylib Fatal Python Error: Pythreadstate_get: No Current Thread Vim

pvtl:~ felix$ brew doctor Warning: /usr/bin occurs before /usr/local/bin This means that system-provided programs will be used instead of those provided by Homebrew. I will try it and let you know. staticfloat commented Aug 6, 2012 And if/when you do, please link us to any discussion that goes on, as others may come here looking for answers! this content So if you want you can maintain alternative shell setting for different Python versions and use them when you need to run PyRosetta.

Would England of the 14th Century be capable of producing revolver bullets Who is spreading the rumour that Santa isn't real? Vim Python Error: Pythreadstate_get: No Current Thread I just removed all my brews and installed everything from scratch on 10.8.2 w/XCode-4.5 and XQuartz 2.7.3. NxLsRxLcwJIn particular I fixed the problem using:Everything I have read suggests this is due to conflicting python installations.

We have not yet found the cause, neither solution.

Currently this bug is blocking me, so I look forward to your full patch. Part of it could be may fault, because I coded py2cairo to use the first python-config it finds in your path. Signed-off-by: Mike McQuaid c4515d9 MikeMcQuaid closed this in c4515d9 Sep 10, 2014 xu-cheng locked and limited conversation to collaborators Feb 17, 2016 Sign up for free Fatal Python Error: Pythreadstate_get: No Current Thread Root I updated my patch, which works now with VTK_ENABLE_VTKPYTHON=ON iMichka/[email protected] @dpo @tdsmith I have a question for you.

Mac OS X already provides this software and installing another version in parallel can cause all kinds of trouble. Chrismarsh commented May 18, 2016 @iMichka Ah yes, there it is. My path lists /usr/local/bin before /usr/bin. $ brew --prefix /usr/local $ git -C /usr/local diff Library/Formula/graphviz.rb diff --git a/Library/Formula/graphviz.rb b/Library/Formula/graphviz.rb index fb8b5f2..0115233 100644 --- a/Library/Formula/graphviz.rb +++ b/Library/Formula/graphviz.rb @@ -22,6 +22,7 @@ http://jeffsthemes.net/python-error/python-error-code-193.html But, if I open python and enter import mapnik, the following error comes and python exits: >>> import mapnik Fatal Python error: PyThreadState_Get: no current thread Abort trap: 6 Mac os

puiseux commented Jul 26, 2016 Sorry to be so late, i was on holidays. Was there any particular reason you downloaded a separate python2.7 version rather than use the default 2.7 installation that comes with Mountain Lion? So I had to change all my environment to python3, but I've been wanting to that for a while now anyways. benjaminhawkeslewis commented Sep 9, 2014 Unfortunately, adding depends_on :python does not fix it: (localhost ~)% git -C ~/homebrew/ diff Library/Formula/graphviz.rb diff --git a/Library/Formula/graphviz.rb b/Library/Formula/graphviz.rb index fb8b5f2..a3169a9 100644 --- a/Library/Formula/graphviz.rb +++ b/Library/Formula/graphviz.rb

The actual patch used here is a slightly modified version as the code had diverged between vtk 7.0.0 and the current HEAD">vtk: fix linking to python … This closes #3401 The Therefore, I will try to find a way to put the sitecustomize.py - which fixes these issue - in our site-packages even if no python has been brewed. Pick which one you want to use and uninstall the other. So adding this to the path worked for me: export LD_LIBRARY_PATH=/usr/local/Cellar/python/2.7.11/Frameworks/Python.framework/Versions/2.7/lib:$LD_LIBRARY_PATH stefanoborini commented Apr 29, 2016 • edited @gutia I am surprised it did, but I might be wrong.

I would suggest contacting the pygtk people upstream and seeing if they have a patch/trying to get it narrowed down on their end, as this does not seem to be a What do you get for which gcc ? The actual patch used here is a slightly modified version as the code had diverged between vtk 7.0.0 and the current HEAD">vtk: fix linking to python … This closes #3401 The build 5493)] on darwinType "help", "copyright", "credits" or "license" for more information.>>> import ROOTFatal Python error: PyThreadState_Get: no current threadProcess 68145 stopped* thread #1: tid = 0x8d92c, 0x00007fff92325866 libsystem_kernel.dylib`__pthread_kill + 10,

Already downloaded: /Library/Caches/Homebrew/graphviz-2.38.0.tar.gz ==> Downloading https://trac.macports.org/export/103168/trunk/dports/graphics/gr Already downloaded: /Library/Caches/Homebrew/graphviz--patch-b242fb8fa81489dd16830e5df6bbf5448a3874d5.diff ==> Patching patching file macosx/graphviz.xcodeproj/project.pbxproj ==> ./configure --prefix=/usr/local/Cellar/graphviz/2.38.0 --without-qt --with-q ==> make install 🍺 /usr/local/Cellar/graphviz/2.38.0: 504 files, 69M, built in 54 seconds Try solution: python-config --ldflags copy the output to corresponding MakeFile.